An Enphase Ensemble Installation

svetz

Works in theory! Practice? That's something else
Joined
Sep 20, 2019
Messages
5,630
Location
Key Largo
Hurricane season runs through November, but September is the historically most active season.... so I find myself wondering what I should set the off-season charge voltage to.

When storing Li batteries, the recommended SoC is usually around 40%. What do you do when batteries are for emergency use? Keeping them at 100% all the time isn't good for them, although I've yet to see anything that quantitatively tells me how bad. Ideally, they'd be around 40% and brought up to full charge before you need them. But, you don't know what an emergency will occur, and keeping your batteries nearly empty won't help you. So...what to do? When I previously contacted tech support they suggested 90-95%; but did so without asking me any particulars and one size doesn't fit all.

Experience says I have two types of emergencies, one is a hurricane-induced outage that lasts very long. The other is a short duration outage of a couple of minutes to hours that could occur anytime.

From battery university we know the closer you get the charge/discharge cycle around the 50% mark the greater the life-cycle.
The warranty of the Encharge 3 at 100% SoC is >70% capacity, up to 10 years or 4000 cycles.

Each Encharge 3 unit has 3.36 kWh of usable power of 3.5 kWh. 3.36/3.5 = 96%. Easy to see why they have 70% capacity at 4k cycles.

If I was cycling every day and wanted to hyper-mile the batteries 75% to 85% would probably be a good target. As these batteries are only for emergency power, in the off-season the power might only be off for an hour at a time. That's about 25% capacity without taking any actions to curtail consumption. Call it 15% above and below 50%, so in the off-season here perhaps a 65% SoC?

Even in hurricane season, with storm guard it might make sense to keep the SoC lower. What's really missing is understanding the degradation due to long-term stead capacity at a single SoC. If you have thoughts on that, I started a new thread on the topic.
 
Last edited:

svetz

Works in theory! Practice? That's something else
Joined
Sep 20, 2019
Messages
5,630
Location
Key Largo
From references in this thread it looks like the break point for the maximum SoC to minimizing aging is around 70-80%
1602174011156.png
 

GXMnow

Photon Sorcerer
Joined
Jul 17, 2020
Messages
1,872
Our systems are a bit different as I have NMC cells instead of LFP, but storage state of charge aging is similar, just the voltages are different.

The way I (am trying to) have my system cycle, I end up at about 51 volts or 50% state of charge (3.65 volts per cell) at the end of my 4 - 9 PM run. So that is my resting battery state for almost 11 hours of the day.

I only hit full charge for an hour or so when it charges up from 8:45 am to 3:55 pm. For now I just run it up to 57.6 volts, which equates to about 85% to 90% SoC (4.11 volts per cell). At 4 PM is starts using the batteries again to offset the high time of use rate to 9 pm. I may limit the discharge current down a bit more to keep about 60% remaining for overnight. I still don't have my essential loads moved over, so I don't have a clear picture exactly how much power I should have in reserve for a power failure. But 50%-60% should be enough to keep me going until the sun comes up. From my rough calculations, my essential loads should be about 900 watts. So 8 KWH should run all of that for almost 9 hours. If the power went out right at 9PM, I may have to turn off a few things to make it until the sun is making enough power. But after that first night I should be fine. If I stay using the whole 900 watts, that works out to 21.6 KWH's. On a normal day, my solar produces right about that. I did 21.9 yesterday in less than ideal conditions. So it should be able to run the load and charge the battery and have 16 KWH in the pack to run through the night. In theory, I can run 17 hours without solar from a full battery. And we can certainly shut off a few things to reduce that load while the power is out.
 

svetz

Works in theory! Practice? That's something else
Joined
Sep 20, 2019
Messages
5,630
Location
Key Largo
Catch 22
One of the problems with leaving your charge settings at 70-80% is that most BMSes top balance, that is they wait until the cell voltage is pretty high. So it might occasionally be necessary to go to 100% for a day.

... I have NMC cells instead of LFP...
You might be interested in the papers listed in the other thread, some of them had NMC numbers.

The way I (am trying to) have my system cycle, I end up at about 51 volts or 50% state of charge (3.65 volts per cell) at the end of my 4 - 9 PM run. So that is my resting battery state for almost 11 hours of the day. I only hit full charge for an hour or so when it charges up from 8:45 am to 3:55 pm.
That sounds perfect! It's only when you hold them at full charge for long periods it hurts them. Also gives the BMS time to do it's cell-balancing job. Great use case!
 
Last edited:

GXMnow

Photon Sorcerer
Joined
Jul 17, 2020
Messages
1,872
I had not seen that paper, but I did see a few similar to that when I was deciding if I would use the Enphase iQ7's in my system. I know 2 people who had their early M series. 3 inverters dies the first year. And after that, they would lose at least another inverter each year. Because of their experience, and their installer telling them, that failure rate was average, I almost skipped on Enphase completely. But I didn't find any complaints about high failure rates on the iQ6's, and the 7's are reported to be even better. Evidently, they did learn from their huge pile of failed earlier designs. My system has now been running for 15 months and not a single issue, other than the odd lockup when my XW takes over the grid forming. And Enphase says they are seeing this on Tesla Powerwall2 systems as well. They are looking into a software fix.
 

svetz

Works in theory! Practice? That's something else
Joined
Sep 20, 2019
Messages
5,630
Location
Key Largo
The last couple of months have been fairly overcast, I'd hoped by now we'd start producing more then we consume. Not sure if its been unusually wet/hot, or it that's the new normal (purple is the house consumption, green is solar production). Did finally pass the 10 MWh generation mark.

1603194489450.png

Was looking around at local weather stations trying to figure out if we've been abnormally hot/wet, but the data is all over the place. But, near as I can figure out.... temperature to the left and rain (Cloudiness) to the right
1603233616737.png 1603233639790.png
 
Last edited:

svetz

Works in theory! Practice? That's something else
Joined
Sep 20, 2019
Messages
5,630
Location
Key Largo
Found an interesting report in SAM regarding local Air Mass under profiles:
1603233951406.png
 

Hedges

I See Electromagnetic Fields!
Joined
Mar 28, 2020
Messages
11,576

"Relex, a respected reliability engineering company that performs reliability testing for organizations such as Boeing and the U.S. Military, determined the Enphase Micro-inverter MTBF of greater than 300 years."

I've generally see this done as a study of components, their voltage (or other) stress, and projected life. I also saw it deliver MTBF numbers far longer than actual experience because something else usually bites you. It represents a best possible result.

Sounds like Enphase put their field experience to good use.

Having 20 Enphase each with 300 year MTBF means you expect one failure in 15 years. String inverter, one failure in 15 years. Obviously much better to have one redundant unit out of 20 fail than your one-and-only.

If they do have the parts (especially transistors) operating further from voltage/current spec limits, temperature rise only 15 degrees (far below limit), and sealed water tight, that is a big boost to reliability.

I've had 5 string inverters for 15 ~ 17 years. One failed (blew a trace, probably due to shorted part) a couple years in, replaced under warranty. One died around 10 years and I reconfigured PV strings around 4 remaining. So my data point is right around what they published for string.

Maybe this indicates micro inverters are a good match for consumer who installs 20 of them. String inverters for a commercial customer who installs 20. 4 MW inverter for a utility who installs 20?

But, granularity is an issue in optimizing expenditure. micro inverters are similar wattage to single panels, so one or the other has wasted capability.

Single-phase inverters have to drive ripple current in caps, which ages them. 3-phase is ideal, because there won't be any 60 Hz ripple in the caps, only whatever ripple due to the higher frequency used to synthesize sine wave.
 

GXMnow

Photon Sorcerer
Joined
Jul 17, 2020
Messages
1,872
I do have to wonder what kind of cap Enphase is using to give the warranty they have on the iQ7's etc. They can't be any normal electrolytic to survive on a roof here in So Cal. They must be some form of a solid electrolyte design. I am sure they use a high frequency synthesis to create the 60 Hz wave from the DC. And with how small the whole inverter is, I will also bet they do not have a 60 hz transformer in there either. Even at just 240 watts, the transformer would make it larger and heavier. So the MPPT is probably a boost type switcher that makes about 350 volts, then it uses an H bridge operating as a high frequency PWM to form the sine wave with just a small output filter to get rid of the switching noise, just like a modern Class "D" audio power amplifier. In this way, all the caps really don't have to be large values. All of the ripple currents are actually up at the high switching frequencies of the MPPT input and the PWM output modulator. All 16 of mine are still working perfectly. And I really do like having 16. If one does fail, I still have 15 working as I get a replacement. One of my co-workers string inverter system was down for nearly 2 months in the hot summer waiting for a new board to be installed by his solar provider.

My Schneider XW-Pro battery inverter is a totally different beast. It is using a high frequency H bridge at the battery voltage. It then uses the filtered 60 Hz sine wave into a massive 100 pound toroid transformer to get from about 40 volts RMS up to the 120/240 split phase output. So when it is feeding 20 amps into my panel, the H bridge is dealing with a 120 amp sine wave. The primary wires in the transformer have to be huge. The 240 volt secondary leads are at least #10 awg.
 

svetz

Works in theory! Practice? That's something else
Joined
Sep 20, 2019
Messages
5,630
Location
Key Largo
Storm Guard Vs. Heat

Saw this on the Enphase site... a response says it is fixed now... but might want to leave it off or only turn on when needed if this applies to you...
Why does Stormguard trigger during heat events? I wasn't allowed to turn it off.
Stormguard automatically charges my battery using utility power during extreme weather events. It recently triggered when we had a high heat warning, even though rolling blackouts weren't threatened. That cost me money since power rates quadrupled during the hot spell, so I was paying top dollar to buy electricity I didn't need. For days, I couldn't sell back to the utility from the battery either, so each day I missed out on selling at high rates or storing cheap solar energy use when the rates were high. I tried to shut off Stormguard but the app would not allow it. (It kept saying "try again" but the button to turn it off would not respond.)
 

svetz

Works in theory! Practice? That's something else
Joined
Sep 20, 2019
Messages
5,630
Location
Key Largo
With the approaching storm I've been waiting to see if Storm Guard would fire off. It did!

But, it'll be interesting to see what it does... The weather service Enphase uses probably got their data from the NWS:
...TROPICAL STORM WARNING REMAINS IN EFFECT...
UNCERTAINTY IN TRACK, SIZE AND INTENSITY: Potential for wind 58 to 73 mph
Window for Tropical Storm force winds: Sunday evening until Monday evening

Sent:11:04 EST on 11-07-2020
Effective:11:04 EST on 11-07-2020
Expires:18:15 EST on 11-07-2020

The problem is the expiration on the bulletin versus the window for winds. Obviously we're in for some rough weather for a few days. I imagine the NWS will keep updating the bulleting, hopefully the service won't keep flip-flopping. I'll let you all know how it goes. Really hoping they have the bugs worked out.

Not quite sure how, but almost made 8 kWh today.

Update: The notices kept getting extended as expected and the system did not ping-pong. Once they issued the all clear the system reverted ... so it petty much worked perfectly.
 
Last edited:

svetz

Works in theory! Practice? That's something else
Joined
Sep 20, 2019
Messages
5,630
Location
Key Largo
So Storm Guard stayed on the whole time, it's still on (things have calmed down, but we there's still a 60% chance of gusts over 58 mph). So, looking good.

Noticed that the Envoy and the Itron meter don't match up will on the amount of power exported to the grid:
Meter​
Envoy​
Delta​
10/31/20 7:57 AM​
17​
14.1​
17.06%​
11/2/20 6:28 AM​
15​
13.2​
12.00%​
11/4/20 7:00 AM​
9​
7.9​
12.22%​
11/6/20 7:00 AM​
8​
5.8​
27.50%​

I can't compare imported or consumed as Envoy ticks over at midnight and my PC is typically sleeping by then. It seems to be consistently under, worse with lower current... so probably the CT's precision is more accurate at higher currents. Guess I need to add more panels! 😉

UPdate: 3/26/21 - Enlighen numbers are matching well now with the meter, probably a software update.
 
Last edited:

GXMnow

Photon Sorcerer
Joined
Jul 17, 2020
Messages
1,872
With my setup, I have to do human "Storm Guard". I lowered my export current a bit during the peak time so I am leaving the battery closer to 70% charged. With this cold weather we have had, my A/C is not running and I did have a few days where I ended up at near zero total consumption. But yeah, I think I need a few more panels too. Not going to get them by year end though. I still have not had a real power failure since I got the backup system working. Have you had any failure that the system covered for you?
 

svetz

Works in theory! Practice? That's something else
Joined
Sep 20, 2019
Messages
5,630
Location
Key Largo
...Have you had any failure that the system covered for you?
I've done simulated failures, it's how I knew I needed the soft-starter. Other than tests I've only had one outage so far that lasted less than 5 minutes.

I feel confident that if I didn't have the system all those storms would have hit here and the power would have been out for weeks.
From wikipedia:
So far, there have been a total of 31 tropical or subtropical cyclones, 30 named storms, 13 hurricanes, and 6 major hurricanes.
But to my count, 35 named storms so far (Iota being the 9th letter in the Greek alphabet)
 
Last edited:

svetz

Works in theory! Practice? That's something else
Joined
Sep 20, 2019
Messages
5,630
Location
Key Largo
Erroneous Discharge?

Looks like the Encharges discharged into the grid when they weren't supposed to. Had a notification in the Enlighten App to contact my installer. Sent the data to them to send to Enphase, but here it is for you too!

Basically the notification said it lost contact with the Encharge units. But when I looked at the graph I also saw a big discharge. At first I thought the batteries went down due to an outage, but the discharge was too large and the CTs showed it exported power?
1605966308963.png

Here are what I think the key messages from the logs are, duplicates removed.... start at the bottom and work up to see them chonologically.

06:48 "EnchargeOnGrid"
06:48 "EnchargePCUStateThrottled"
06:48 "EnchargePCUFullyOperational"
06:48 "Multi Mode On-Grid"
06:48 "EnchargePCUStateGridFault"
06:48 "EnchargePCUFault"
06:48 "Grid-Tied"
06:47 "AC Frequency Out Of Range","Encharge Micro"
06:47 "AC Voltage Out Of Range","Encharge Micro"
06:47 "EnchargeIslanding","Encharge Controller"
06:46 "Microinverter failed to report: Clear"
06:47 "EnchargeIslanding","Encharge Controller"
06:47 "Islanding","Encharge Micro"
06:40 "Power On Reset"
06:40 "High Skip Rate"
06:40 "DC Voltage Too Low: Set"
06:40 "Microinverter failed to report: Clear"
06:03 "SOC below reserved level : Clear", "envoy"
05:59 "EnchargeSoCMaintenance : Clear","Encharge Controller"
05:58 "EnsembleModGone : Clear","envoy"
05:58 "EnchargeGridModeFromEnvoyMMOnGrid","Encharge Controller"
05:58 "EnpowerAgfProfilePropogationDone","Enpower Device"
05:57 "EnchargeGridModeFromEnvoyUnknown","Encharge Controller"
05:51 "EnchargeZigbeeCommFailure : Set","Encharge Controller"
05:55 "Device is excluded from the aggregate SOC: Set","Encharge Controller"
05:54 "SOC below reserved level : Set
05:54 "EnsembleModGone : Set","envoy"
05:51 "EnsembleDevicePingReceived"
02:42 "EnchargeGridModeFromEnvoyMMOnGrid"
02:42 "EnchargeGridModeFromEnvoyUnknown"
 

svetz

Works in theory! Practice? That's something else
Joined
Sep 20, 2019
Messages
5,630
Location
Key Largo
Enlighten (Enphase web reporting tool) says it's down due to AWS (which is Amazon Web Service or Amazon’s cloud service).

1606389609642.png

I don't know that AWS has ever fully failed given their distributed setup around the world and healthy paranoia. So, more likely an Enphase issue where they goofed and aren't properly distributed or can switch between service centers upon failure detection.
 

GXMnow

Photon Sorcerer
Joined
Jul 17, 2020
Messages
1,872
I was getting the same message. Had virtually no data for over a day. Looks to be back up to normal report speed this afternoon though. I had no idea my data had to go to Amazon to get from my roof to my desk.
 

svetz

Works in theory! Practice? That's something else
Joined
Sep 20, 2019
Messages
5,630
Location
Key Largo
Well shoot... lost 4 days of grid-meter readings... looks like a windows update helpfully reset the driver for my SDR dongle.

Trimmed the tops off the "near" trees I could easily get to from the roof (had one branch grab the pole saw as it fell, almost jerked it to the ground, glad I wasn't using the shoulder strap!).

How much difference did it make? Before, my two worst shaded panels compared to unshaded were: 70% and 83%... yesterday they were 70% and 81.6% <sigh>. Well, only 20 more days to the solstice.

Now I have 5 trash cans full of leaves... I just snipped the end bits with leaves off so I wouldn't have to rake up leaves. Still have to cut up and trash the branches... so a lot of work for nothing 😉
 

GXMnow

Photon Sorcerer
Joined
Jul 17, 2020
Messages
1,872
I had 3 palm trees cut down at the end of last year, and the difference is dramatic.
Going back 2 weeks to when I had no cloud issues in either this year or last year, so the only real difference is the trees.
November 2019 2020

13th 10.3 KWH 18.9 KWH
14th 10.7 18.4
15th 9.8 18.2
16th 10.2 18.6
17th 10.5 18.5

totals 51.5 92.6

That works out to an 80% increase in production from last year to this year. As we get close to the solstice, I am still getting some shading at the very end of the day from the last 2 palm trees, but they are not costing me that much as the non shaded panels on the higher roof are already down to about 30% of peak when the lower roof starts getting the shadows. You can still see the production dip from the ideal parabola, but it's certainly not worth cutting the other trees... yet. I know my array is a lot smaller than yours, so my numbers might not be impressive. This is just 16 300 watt panels. So if we do this in raw "sun hours" In November 2020, I am getting about 3.85 x my DC panel rating of 4,800 watts. Back in May 2020 (my best month yet) I was getting over 30 KWH a day, or 6.25 sun hours. And that is after all of the inverter losses and even with some clipping in the 240 watt inverters.
 
Top