diy solar

diy solar

Anyone having trouble with chinese pump controllers?


New Member
Jul 25, 2021
I put in a bore a couple of years ago with a chinese bore pump (nominally 72V, 750W, 5m3/h)
It worked well for two years and then the controller failed.
The pump is 3ph which is generated from the (DC only) controller which has a few user configurable parameters, but is mostly locked down.
The supplied controller is rated 150V max input. My PV setup is 3s2p providing 106V on a cold morning dropping to 100V in full sun (cold is a relative term - say 10°C)
About a month ago, the controller started throwing errors (low power mostly). I contacted the salesman who had supplied it and he put me onto a series of diagnostic youtube vids.
First approach was to lift the pump and separate the pump from the motor. There was no resistance turning the pump. The motor is firm to turn by hand - I not sure what "normal" feels like, but it just feels like strong magnetic pole resistance.
The three pump windings all measure 1.2 Ohms (so no problem there)

Following the test procedure, it was confirmed four of the six power FETs had failed (taking out two phases).
I ordered a dozen new FETS, but as they were coming from the UK (to Oz), I ordered a replacement controller too. The new controller arrived first, so was put into service. It worked perfectly for ten days before also failing (different error this time, but same effect) - this time three FETs failed - one on each phase.

Anyone else had similar fun with these pumps?

Many chinese manufacturers are using the same controller box. Not sure if they are the same inside of not.

For anyone with an electronics interest, the FETs are: IRFB4127
Last edited:
Sounds like something in the pump or wiring in-between is taking out the controllers.

I have only dabbled with with a few of these pumps and they are working so far. My controller looks different but very well may be the same inside.

I assume your pump is a centrifugal? Mine are helical rotor (positive displacement) style.

Both controller and pump are so cheap I will probably just replacement them both at the same time, rather than attempt any deep troubleshooting.

Sorry I wish I could be more help.
Thanks for the reply.
Normally these pumps ship with a 2m power cable, but I got this one built with full length cable so there was no need for underwater splices and sourcing waterproof cable - naturally, delivery was a bit slower, but it wins on several other fronts.
Yep - it's an impeller pump.

not sure what your price is, but here they are around us$6~700, so I'd like to know why these two have failed before dropping another down the hole.

do you have this controller?
I have nothing to add but I was considering these , eBay has them around $300 us for pump and controller ...
If low power, it is likely the capacitors failed. They can be worked pretty hard in this application. I'd put some in parallel with input power externally. A semiconductor failure would cause it to not work at all.
Following their own test procedures, it's the FETs that are blown.
The two big electrolytics are across the supply, so don't work hard at all.

I picked up the fresh FETs tonight, so I'll have them installed in the original controller early next week.


The pump comes with a 2 year warranty and as it was 25 months, the best I could do was a bit of a discount on a new controller.
The new controller worked for about a week before it too failed.
"it must be the motor" I was then told. "Test the windings" Windings tested perfect.
"Must have leaked and got water in it". So I pulled the pump (again), separated the pump and stripped the motor.
The oil is clean, the bearing run free, there is absolutely no water in the oil and nothing to suggest a problem.

Given the pump was on the surface, it turned easy enough, but I stripped it anyway ...... then it became clear


This is the top section of the pump which houses the non-return valve, outlet fitting, safety wire attachment etc.
Clearly a manufacturing fault as the stainless steel should easily cope with the pressure generated by the pump.
Photo's not clear enough but that looks like a design flaw rather than a manufacturing issue, a sharp bend in a pressing has created a stress riser.
I personally don’t like these kind of pumps. I usually use regular 3 phase ones with solar motor inverters. Have two of them and never failed. My wife’s uncle have 3 of these solar pumps and already have 2 failures with them.
@kommando , apart from an academic interest, design vs manufacturing issue, I don't really care - it should not have failed.

@gfjardim , what pumps do you use? and what inverters? Obviously I need something better than what I have.
Thanks - that would be difficult to setup here as 220V 3ph doesn't exist (we use 415V 3ph), so pumps are not available.
Here in Brazil we have 220v 3ph and 380v 3ph systems. The 380v have a much wider PV limit and requires a larger number of panels, so we use it only with pumps with more than 2.5 hp.

Here we have Ebara and Franklin Eletric solar pumps available. Probably they are greater quality from these other OEM pumps.