diy solar

diy solar

Elefast 100AH battery - BMS shuts down - claims over temp 90C ?

eXodus

Solar Addict
Joined
Jul 27, 2020
Messages
1,485
I had my RV sitting the last days and it was charging with a 100W panel and LFP charging profile.

So today I came into the RV everything dead. - So I pulled up the Bluetooth app and the BMS claims that the battery is at 90C and the Discharge MOS is disabled.


435480860_451429793990750_5191887922442268127_n.jpg

A bit nervous I got a wrench and removed the battery from the bay - touched it - and dead cold. Nothing, the terminals, case, nothing is more then ambient.

Cell voltages look fine, not sure what I am dealing with.

Is there a possibility that the BMS has a wrong reading ? It just sits at the 90C - goes up and down half a degree,
Is there a way to reset the BMS?

I put it out on the driveway just in case it wants to blow up overnight.
 
sounds like a temperature sensor fault. Can you deactivate it in the BMS settings and restore function?
My assumption as well. Nothing to disable a temp sensor I can see in the BAT-BMS app.

Any other Android Apps to recommend which may have more features?
 
Was there a temp sensor lead in the kit that you forgot to install?
Aka it howls because of no signal back from said missing lead?
 
Have you measured the voltage with a meter?
Could it be in LVD?
On the Terminals the voltage is about 6V

Yet since the Bluetooth BMS shows that it has disconnected the output because of high temperature - not sure what to make of it.

Was there a temp sensor lead in the kit that you forgot to install?
Aka it howls because of no signal back from said missing lead?

It is complete battery - nothing I put together, and I can not get to sensor without cutting it open. Since the battery is only 3 months old - I have warranty and will not do that.

I wrote the manufacturer. Lets see.
 
The support responded very quickly within hours and we setup a time for them to remote into the BMS and have a engineer check it out.
I needed to bind the their app to the battery so they could access it through the bluetooth code.

Now the temperature values are looking normal again and both charge and discharge FETs are back on.

Will do some testing tonight and see if everything is back to normal.
 
Battery behaves perfectly normal again.

Have to say that's some good support and things you can do these days. Someone from the other side of the world is remotely fixing the battery in my RV via the Bluetooth connection on my phone via their app.

Modern technology continues to amaze
 
On the Terminals the voltage is about 6V
On a similar JBD BMS, the output voltage with the BMS output switched off in the app, and no load whatsoever, shows 8V, so this might be what your were reading. I imagine if you added even a small load it will drop to 0V.


sounds like a temperature sensor fault. Can you deactivate it in the BMS settings and restore function?
My assumption as well. Nothing to disable a temp sensor I can see in the BAT-BMS app.

Any other Android Apps to recommend which may have more features?
Sure can - try the Overkill app - it has full control of all the settings, including voltage and temperature cutoffs, etc.
Beware, though, the app is capable of harming the battery and everything connected to it.
I recommend to screenshot the default settings when you first fire it up.

And I just ordered this same Mini battery - think it will do a fine job as a trolling motor battery.
Please report back if that Overkill app works with it!
 
Sure can - try the Overkill app - it has full control of all the settings, including voltage and temperature cutoffs, etc.
Overkill connects to the Elefast battery. Just tried it.

Much more settings available. Thanks!
 
Last edited:
Battery behaves perfectly normal again.

Have to say that's some good support and things you can do these days. Someone from the other side of the world is remotely fixing the battery in my RV via the Bluetooth connection on my phone via their app.

Modern technology continues to amaze
Can you provide the contact info for Elefast? I have a battery that won't charge also. Tried 3 different 20a chargers and get the same. It will charge 2-5 amps for a few seconds and then nothing.
 
Can you provide the contact info for Elefast? I have a battery that won't charge also. Tried 3 different 20a chargers and get the same. It will charge 2-5 amps for a few seconds and then nothing.
It was through the Amazon - contact Seller page.
I don't have a direct contact.
 
Back
Top