Felicity LPBA unbalanced cells

abdallah.91

New Member
Joined
Sep 11, 2021
Messages
45
Hello dears,

I am importing Felicity LPBA 48V 170 Ah 16s1p LiFePo4 battery which defined to be CATL grade A cells from China. unfortunately 1 battery I installed it for my sister's house after it gets fully charged from utility for example and restrd long time on around 54v but stops charging by BMS and shows 100% SoC, when utility or sun disappears so inverter starts taking power from the battery and even it take just few ampers from it, after few minutes its voltage drops to around 52.5v or less and SoC is showing 98% for example. does this voltage suits that SoC? and the voltage drops fastly to 52.5V which is logically indicates <75% but BMS SoC is showing above 95%?
yesterday when the battery has got fully charged from the utility and stopped charging I connected the BMS to the PC monitor I surprised that difference between cells reached 0.2v as the attached photo shows. is it logic for a new battery?

please tell me your feedback.
 

Attachments

  • IMG_20220614_223959.jpg
    IMG_20220614_223959.jpg
    1,006.4 KB · Views: 13

time2roll

Photon Sorcerer
Joined
Mar 20, 2021
Messages
3,846
54 is a bit low for BMS shut down. Yes the cells could be better balanced but not drastically terrible. I recommend reducing charge voltage by 200 mV increments until the BMS no longer shuts down the battery. Let it run several weeks and see if the balance improves.
 

Scixxor

Solar Novice
Joined
Nov 23, 2021
Messages
150
Although I'm not certain this is true for LifePO4 when I connect any sort of load to my GEL batteries the voltage immediately drops, as soon as the load goes away it goes back up. Essentially the voltage drops under load but you haven't actually lost that power it just looks that way. I would try disconnecting your inverter when this happens to see if the voltage goes back up. If so then it seems like everything is working as it should be.
 

Blackmoses

New Member
Joined
May 20, 2022
Messages
11
Hello dears,

I am importing Felicity LPBA 48V 170 Ah 16s1p LiFePo4 battery which defined to be CATL grade A cells from China. unfortunately 1 battery I installed it for my sister's house after it gets fully charged from utility for example and restrd long time on around 54v but stops charging by BMS and shows 100% SoC, when utility or sun disappears so inverter starts taking power from the battery and even it take just few ampers from it, after few minutes its voltage drops to around 52.5v or less and SoC is showing 98% for example. does this voltage suits that SoC? and the voltage drops fastly to 52.5V which is logically indicates <75% but BMS SoC is showing above 95%?
yesterday when the battery has got fully charged from the utility and stopped charging I connected the BMS to the PC monitor I surprised that difference between cells reached 0.2v as the attached photo shows. is it logic for a new battery?

please tell me your feedback.
First you need ro educate yourself about lifepo4 battery charging and balancing. I suggest you watch Andy channel as he made a lot of experiments about charging voltages

Here’s a post LINK about my would be charging profile after reading victron suggestions and watching Andy videos. Wish it helps you.
 
Last edited:
Top