Growatt 48V SPF 3000TL LVM Flickering LED Lights.

Wpfrogs

New Member
Joined
Jan 5, 2022
Messages
6
I purchased a Growatt SPF 3000TL LVM invert 6 months ago and ran it on solar and grid only with no problems at all. Really like the Growatt product. I just recently installed two EG4LL 48v batteries to the system and now I'm have flickering LED light problems. It's driving me crazy. There are no refrigerators on the system and the Growatt is not in power saving mode. I don't understand why the batteries are affecting the system this way when the solar panels on their own didn't cause any problems. I've researched this problem to no end. Contacted the supplier which didn't help. I was wondering if anyone else with this model are having the same problems? Is there a fix for it? Any recommendations on a different inverter? Thanks for any help
 
  • Like
Reactions: GTO

RichardfromEG4

The "Do-What's-Needed" Solar Guy
Joined
Dec 23, 2021
Messages
705
Location
Sulphur Springs, TX
I purchased a Growatt SPF 3000TL LVM invert 6 months ago and ran it on solar and grid only with no problems at all. Really like the Growatt product. I just recently installed two EG4LL 48v batteries to the system and now I'm have flickering LED light problems. It's driving me crazy. There are no refrigerators on the system and the Growatt is not in power saving mode. I don't understand why the batteries are affecting the system this way when the solar panels on their own didn't cause any problems. I've researched this problem to no end. Contacted the supplier which didn't help. I was wondering if anyone else with this model are having the same problems? Is there a fix for it? Any recommendations on a different inverter? Thanks for any help
Hey there! I'm Richard with Signature Solar and we do a lot of support on Growatt inverters (and the EG4 Batteries are obviously from us!). Just wanted to check and see if you have reached out to our tech support team? If not, give us a call. If you have, send me your contact info in a message and I'll find out what is going on and get a solution for you one way or another. Thanks!
 

740GLE

Solar Addict
Joined
Apr 30, 2021
Messages
986
How’s the bonding of the system? Are you still connected to utility?
 

740GLE

Solar Addict
Joined
Apr 30, 2021
Messages
986
Prove it with pictures/diagrams. Your assumption maybe a huge oversight.

What are the grow watts settings?
 

Wpfrogs

New Member
Joined
Jan 5, 2022
Messages
6
Thank you, Richard, for suggestion I give you guys a call. I spoke with Matt, and he had me change setting 01 from SBU to SOL and I believe that fix the problem. I'll update this thread if notice any flickering. Thanks again
 

Zwy

Photon Sorcerer
Joined
Jan 3, 2021
Messages
1,630
Location
Timbuktu
See this Youtube video:


Same inverter...same complaint
 

jpimlott

Solar Enthusiast
Joined
May 15, 2020
Messages
30
Thank you, Richard, for suggestion I give you guys a call. I spoke with Matt, and he had me change setting 01 from SBU to SOL and I believe that fix the problem. I'll update this thread if notice any flickering. Thanks again
That just turns off the inverter at night , so no flickering
Have they come out with a real fix to run on batteries and not flicker
My lights flicker when i have a computer behind an UPS.
 

Wpfrogs

New Member
Joined
Jan 5, 2022
Messages
6
Your right my problem came right back. I upgraded my firmware in my Growatt from 51.03 to 51.04 and some of my lights stopped flickering. The unit has issues when there is not enough load on the system. I've tried all kinds of different LED light bulbs with no luck. My house is not running totally solar, so I picked circuits that had the least amount of flickering going on. It was a trial-and-error way of going about it. Finally found a combination of circuits I could work with. I defiantly understand your frustration, especially if you're using the Growatt to run you whole electrical system. Other than that, it's been pretty reliable. After running for a year, the only other problem I've had is the software locked up and shut the system down. I just restarted the unit and it's been working fine ever since. Growatt needs to come up with a fix for this. Below is a link to the firmware I used.

 
Top