New Power Supply/Charger Problem

pacard17

New Member
Joined
Nov 18, 2021
Messages
5
Hello,

I just purchased a Dr. Meter PS-3010DF power supply. I'm building my first LiFePO4 battery (12v, 100ahr). I'm attempting to top balance the cells. They are currently wired in parallel. I've set the charger to 3.65v & constant voltage mode. I've followed the directions which state I must:

1. Turn both of the current knobs clockwise as far as they’ll go

2. Adjust to the voltage I want

3. Connect whatever I’m charging to the power supply

However, as soon as I do this, it switches to constant current mode instead of constant voltage mode. Any idea what I'm doing wrong or how to fix this?

Thanks!
 

sunshine_eggo

Happy Breffast!
Joined
Oct 26, 2021
Messages
3,541
Location
USA
Hello,

I just purchased a Dr. Meter PS-3010DF power supply. I'm building my first LiFePO4 battery (12v, 100ahr). I'm attempting to top balance the cells. They are currently wired in parallel. I've set the charger to 3.65v & constant voltage mode. I've followed the directions which state I must:

1. Turn both of the current knobs clockwise as far as they’ll go

2. Adjust to the voltage I want

3. Connect whatever I’m charging to the power supply

However, as soon as I do this, it switches to constant current mode instead of constant voltage mode. Any idea what I'm doing wrong or how to fix this?

Thanks!

It is functioning correctly.

The cells are pulling the voltage down to them. That is normal.
 

pacard17

New Member
Joined
Nov 18, 2021
Messages
5
thanks for responding! i understand it's pulling the voltage lower. but why is switching to constant current mode instead of remaining at constant voltage mode?
 

sunshine_eggo

Happy Breffast!
Joined
Oct 26, 2021
Messages
3,541
Location
USA
thanks for responding! i understand it's pulling the voltage lower. but why is switching to constant current mode instead of remaining at constant voltage mode?

Because as you've seen, it's not in constant voltage mode. It's in constant current mode. Once it raises to 3.65V and begins tapering the current, it will be in constant voltage mode.

Constant means not changing. Voltage is changing. Current is not.
 

pacard17

New Member
Joined
Nov 18, 2021
Messages
5
i've watched multiple videos w/ similar chargers that can maintain constant voltage despite SoC. Amps go down as the batteries approach a full charge. just trying to figure out why this charger won't remain in a constant voltage mode.
 

sunshine_eggo

Happy Breffast!
Joined
Oct 26, 2021
Messages
3,541
Location
USA
i've watched multiple videos w/ similar chargers that can maintain constant voltage despite SoC. Amps go down as the batteries approach a full charge. just trying to figure out why this charger won't remain in a constant voltage mode.

Because you got lucky. Those chargers you describe have so much resistance in the unit/wires/connections, the PS reads 3.65V when the cells are still at 3.3X, so current is less than the 10A. This means it takes longer to charge. You set to 3.65, but the voltage drop between the cells and the power supply is not so large that it's in constant voltage mode.

You WANT what is happening right now. You don't WANT what you're seeing in the videos until you near full charge. MANY build new leads and use ring terminals to try and limit the voltage drop so 10A is delivered longer.

Measure the cells with a meter. It will be lower than what the PS reads.

I don't know how to put it any more plainly....

If voltage is changing, it is in constant current mode, because current is... constant.
If current is changing, it is in constant voltage mode, because voltage is... constant.
 

pacard17

New Member
Joined
Nov 18, 2021
Messages
5
i can confirm your statement. i had been using a heavier gauge wire instead of the default alligator clips that came w/ the power supply. i just tried the alligator clips instead. it works as expected in constant voltage mode when using the clips. but it only puts out 4a. when i use my heavier wiring, it goes to constant current mode and puts out 10a.
 

tjoiner1986

Solar Enthusiast
Joined
Jan 10, 2022
Messages
83
Location
Sheffield, AL
Just so I'm clear before I toast a lot of expensive stuff...

Setting the voltage on the power supply to 3.65V and then watching it drop to around 3.45V once connected to the LFP battery bank is normal?

I'm sitting here at work right now, about to start top balancing since I don't have anywhere else to do it. I've got my 4 cells in parallel, 30V/10A Amazon power supply set to max current and 3.65V BEFORE connecting to the battery, 15" long 4 AWG cables between power supply and battery. I started top balancing but flipped everything off when I saw the voltage readout on the power supply drop. I wasn't sure if that was normal.
 

sunshine_eggo

Happy Breffast!
Joined
Oct 26, 2021
Messages
3,541
Location
USA
Just so I'm clear before I toast a lot of expensive stuff...

Setting the voltage on the power supply to 3.65V and then watching it drop to around 3.45V once connected to the LFP battery bank is normal?

Yes. Very much. You want to see this. Two things in parallel must be at the same voltage. This drop ensures that you can deliver the set amps. If the display said 3.65, then it would start tapering the amps.

I'm sitting here at work right now, about to start top balancing since I don't have anywhere else to do it. I've got my 4 cells in parallel, 30V/10A Amazon power supply set to max current and 3.65V BEFORE connecting to the battery, 15" long 4 AWG cables between power supply and battery. I started top balancing but flipped everything off when I saw the voltage readout on the power supply drop. I wasn't sure if that was normal.

4awg sounds luscious. Get back to charging. Before you ask, yes, the voltage will barely budge for very long periods of time and might even drop from time to time.

The voltage that matters is the one you measure at the cells with your voltmeter. The difference between the unit and your meter is the voltage drop - resistance in the test leads and the unit itself.

Assuming 280Ah cells @ 50% SoC as received: 140Ah * 4 = 560Ah. 560Ah/10A = 56 hours of charging... almost certainly more - by as much as 50%.
 

tjoiner1986

Solar Enthusiast
Joined
Jan 10, 2022
Messages
83
Location
Sheffield, AL
Thanks! I appreciate all of your help -- and your speedy response!

Before connecting, I dialed back the current just a little so I wasn't running this cheap power supply at full throttle. I'll have to leave this charging overnight I imagine and don't want to burn down my place of employment. Pretty sure the boss wouldn't like that.

The cooling fan just cut on and it startled me. :oops:

PXL_20220125_171513167.jpg

PXL_20220125_171526832.jpg
 
Top