Newbie Question about SOC vs Voltage

Scott Martinez

New Member
Joined
May 3, 2020
Messages
52
Hi, I have two 24v EG4's setup in parallel to my split phase setup with 2 MPP Solar LV2424's. I am trying to set some conservative settings to retain some storage for an actual power outage. The battery nominal voltage is listed as 25.6 volts.

I have them setup to stop discharging at 24 volts. I noticed that when the inverters switched to utility at 24 volts the morning, the SOC indicator on the batteries were 0% and I had a low battery warning/alarm light was on. I have set the low voltage disconnect at 22 volts in case of actual power outage and no solar or utility available.

Since this is a 25.6 nominal battery, is my 24v switch to utility setting too low? Or is this just some of the cells not being balanced yet? The SOC indicator and the voltage listed on the inverter don't entirely seem in line.

Battery specs:

Thanks!
 

papab

Solar Enthusiast
Joined
Oct 30, 2021
Messages
41
It sounds like its out of balance and it cutoff due to low voltage on a cell even tho the battery voltage is OK. Do you have the BMS PC software? Does it show you cell voltages?
 

Scott Martinez

New Member
Joined
May 3, 2020
Messages
52
That seems reasonable.

How high are you charging them?
Here is a widely accepted voltage vs SoC chart:
View attachment 80727
Thanks for the chart. It explains a lot. The EG4 specs say to Bulk at 28.5 and float at 28.25 and I have set that as close as the PIP's can in the user settings. I set the "switch to utility" to 25.5v which is close to 20% SOC. I was assuming that 25.6v nominal was 100% SOC. DC cutoff is set to 22.5v. We've had some sun the last couple of days, and I am getting close to 100% SOC while running most of the house. I am looking at adding 1 more battery soon to bring storage up to 15kWh.
 

Scott Martinez

New Member
Joined
May 3, 2020
Messages
52
It sounds like its out of balance and it cutoff due to low voltage on a cell even tho the battery voltage is OK. Do you have the BMS PC software? Does it show you cell voltages?
It took a bit to get the serial connection going with one of my laptops. It looks like my 2 server rack units are pretty close. I guess I didn't realize that the EG4's nominal voltage of 25.6 volts was actually only 20% SOC and going below that would set off the Alarm LED.
 

Attachments

  • unnamed (1).jpg
    unnamed (1).jpg
    1.2 MB · Views: 4
  • unnamed.jpg
    unnamed.jpg
    953 KB · Views: 4
Top