diy solar

diy solar

SK48V100 + Cerbo-S GX = No SOC reading (whoops + advice pls)

941all-electric

New Member
Joined
Apr 16, 2023
Messages
9
Location
Sarasota, FL
Hi all,

I recently installed this system (no shunt!):
- two 405W 48V panels;
- Victron 150/35 MPPT;
- SOK 48V 5kWh server rack battery;
- Cerbo-S GX;
- Phoenix 48/1200 inverter.

Everything appears to work great, except I don't see an SOC reading in my Victron VRM Portal.

Looks like I screwed up. When I quickly Googled the difference between the regular Cerbo GX and the 'basic' Cerbo-S GX, I was left with the impression that I was only missing tank sensors in the basic version. Turns out, you also lose the BMS-CAN port, which is what you're supposed to use to connect the SOK48V100 for Victron communication.

So instead, I used a VE-Can port in the Cerbo-S. Fortunately, I do get battery voltage information in the VRM portal.

Help: should I exchange the Cerbo-S? Or just buy a Victron shunt? Or both? What would you do?
 
Odd that you get voltage but nothing else unless it's simply the Cerbo itself reporting it's supply voltage or the voltage reported by another device.

The VE.Can port can be configured to work with a BMS (unless there's a specific restriction on the -S). My CCGX only has one VE.Can port, and I have my Batrium connected to it.

Did you set the bit rate of the VE.Can port to 500Kbps?

Did you install the VE.Can terminator in the other Cerbo VE.Can port?
 
Thank you,

To your first question, I haven't set a bit rate. I see in Sec. 4.5 of the manual that "You can set the VE.Can port from 250 kbit/s to be 500 kbit/s", but it doesn't seem to say how to do that? Should I?

As to your second question, yes, I have a VE.Can terminator on the other Cerbo VE.Can port not being used.
 
Thank you,

To your first question, I haven't set a bit rate. I see in Sec. 4.5 of the manual that "You can set the VE.Can port from 250 kbit/s to be 500 kbit/s", but it doesn't seem to say how to do that? Should I?

As to your second question, yes, I have a VE.Can terminator on the other Cerbo VE.Can port not being used.

Victron hardware is at 250. BMS are at 500. You must change to 500.

Touch screen: Menu, top level is the Device List, which shows what's conntected, Notifications and Settings (top level shown below):

1716932816333.png

Settings > Services (all the way to the bottom/near bottom on the settings screen) > VE.Can port > CAN-bus profile

Select CAN-bus BMS (500 kbit/s)

Your options may be slightly different from mine has I have a CCGX, which doesn't have all the features of even a Cerbo-S.
 
There is no explicit restriction in the manual for the -S. It just doesn't have both ports. The BMS-CAN port can only be set to 250. The VE.Can port can be set to either.

1716934316768.png

As I mentioned, I had no issues configuring and connecting my 500k BMS to the VE.Can port on my CCGX, which only has one port.
 
I don’t believe the Cerbo-S can do it, that’s why I got the standard one.
You can set the ve.can port to communicate with BMS on the cerbo-s. You just can't do both BMS and ve.can with the cerbo-s, for both of those functions at once you need the full Cerbo with the additional pair of ports. In the OPs case he doesn't have any ve.can devices so shouldn't have any issues using the ve.bus port as BMS.
 
Thanks @Brucey and @sunshine_eggo - I switched the VE.Can port to 500kbit. However, I still don't see a SOC for the battery.

When I select "Network Status" underneath the VE.Can setting, I see there appears to be an error. No idea if this is relevant.

Attached are three screenshots of what I'm seeing. Any other thoughts?cerbo-s ve-can settings.jpg
 
Ah, I'm an idiot @sunshine_eggo! You tried to tell me about dip switches up front. I'd made a bad assumption that the battery would ship by default in 'master' state, and because I only had one battery, I didn't need to worry about it.

As soon as I switched the dip switch, it worked. I now see the SoC!

Thank you all, and hopefully this thread is helpful for others in the future.
 

diy solar

diy solar
Back
Top