Top balance done, cells connected, strange BMS reading.

Simi 60

Solar Enthusiast
Joined
Jul 10, 2021
Messages
123
First of 3 x 24v batts being made with A grade matched and batched Eve 280k.
Tried to top balance with a 30v 10a power supply but that would have taken a decade or more so put them back in 24v bank, hooked up the JBD BMS and after a small dipole tweak, got the spare Victron Skylla TG 24v 50a to start smashing in some amps untill it got to around 3.6v/cell.
All good thus far.

Pulled it apart and did cell 1,2,3,4 to 3.64v
Then did same with 5,6,7,8
Reassembled and gave it a wrist twist of compression.

Cleaned aluminium terminals, slight smear of ox-gard, very smooth and shiny busbars on, BMS cables on and torqued to about 7lb/ft

Opens the BMS app and the cells aren't the same and the battery level is zero, but app shows 28+ v
Connect up the benchtops power supply and get the battery at 100% and showing 280ah but cells are still off.

What's the story?

It does indicate that cells are self balancing but why would they need to if I have just done it prior to assembly?
Screenshot_2021-11-18-16-34-55-491.jpeg
 

Short_Shot

Photon Sorcerer
Joined
Jul 13, 2021
Messages
1,820
Based on what you said you did, that's fine.

You didn't actually top balance them so I wouldn't expect them all to be equal.

After taking them off the charger the voltage will settle to 3.5 ish after a full charge so that's also normal.

Since that 3.5v is up into the full soc knee I wouldn't worry about it. They should all be within a fraction of a percent of one another regarding soc.

I would start looking at discharge behavior now. Put a load on the assembled battery and see if they go way out of balance when they're down in the flat part of the discharge curve.

Oh, and 85mv isn't the end of the world as long as youre in the high knee there. The bms will eventually sort that out anyways if it's set up properly.
 

Short_Shot

Photon Sorcerer
Joined
Jul 13, 2021
Messages
1,820
Oh and the battery level is not zero based on that screenshot so I'm not sure what you mean by that.

That "gauge" at the top is for charge/discharge current.
 

Simi 60

Solar Enthusiast
Joined
Jul 10, 2021
Messages
123
Oh and the battery level is not zero based on that screenshot so I'm not sure what you mean by that.

That "gauge" at the top is for charge/discharge current.
When I first started the app the battery curve at bottom was red and reading zero
Remaining ah also read zero.
It wasn't until I connected some slight charge for a few seconds that both of those numbers changed.
 

Simi 60

Solar Enthusiast
Joined
Jul 10, 2021
Messages
123
Based on what you said you did, that's fine.

You didn't actually top balance them so I wouldn't expect them all to be equal.
Really?
I bought all 8 cells to the same voltage with a $50 "high quality" benchtops power supply.
Surely you're not suggesting such high grade gear is not entirely accurate (-;
I would start looking at discharge behavior now. Put a load on the assembled battery and see if they go way out of balance when they're down in the flat part of the discharge curve.
Thats going to be a while yet
Need to do two more same same and then get someone in for the swap out of AGM and wire these in do probably a month away
Oh, and 85mv isn't the end of the world as long as youre in the high knee there. The bms will eventually sort that out anyways if it's set up properly.
Well that's something, I daresay give it a few hours and it'll be closer again.
 

Short_Shot

Photon Sorcerer
Joined
Jul 13, 2021
Messages
1,820
When I first started the app the battery curve at bottom was red and reading zero
Remaining ah also read zero.
It wasn't until I connected some slight charge for a few seconds that both of those numbers changed.
The BMS will not read full charge on the battery until its detected as such. This is done by monitoring charge current. When the charge current drops to a certain level it assumes its at or very near full and resets the numbers.


All seems normal so far.
 

Short_Shot

Photon Sorcerer
Joined
Jul 13, 2021
Messages
1,820
Really?
I bought all 8 cells to the same voltage

Yes but they haven't all had the same time to "settle" since you did them in groups.

It's also possible the top balance of each group wasn't entirely finished as well, depending what the current was when you pulled them off charge.

If you top balanced them all in one parallel pack they would be very nearly the same. However as I said, since you're in the steepest part of the charge curve at that voltage it won't affect anything. You're good to go there.
 

Simi 60

Solar Enthusiast
Joined
Jul 10, 2021
Messages
123
The BMS will not read full charge on the battery until its detected as such. This is done by monitoring charge current. When the charge current drops to a certain level it assumes its at or very near full and resets the numbers.


All seems normal so far.
Good oh
On to batt 2 then
Thanks
 

Simi 60

Solar Enthusiast
Joined
Jul 10, 2021
Messages
123
Yes but they haven't all had the same time to "settle" since you did them in groups.
I did suspect that may have been it
But then I would have thought 1,2,3,4, would be the ones slightly off being first charged and sitting for a couple of hours but it's a 50/50 mix
If you top balanced them all in one parallel pack they would be very nearly the same. However as I said, since you're in the steepest part of the charge curve at that voltage it won't affect anything. You're good to go there.
Great and thanks
 

Short_Shot

Photon Sorcerer
Joined
Jul 13, 2021
Messages
1,820
Good oh
On to batt 2 then
Thanks
I had the same concern with mine the first time I did this.

They also sometimes will report the wrong remaining capacity after you change bms settings. Once again that will reset when it verifies full charge.
 

Simi 60

Solar Enthusiast
Joined
Jul 10, 2021
Messages
123
I had the same concern with mine the first time I did this.

They also sometimes will report the wrong remaining capacity after you change bms settings. Once again that will reset when it verifies full charge.
Thanks again, nice to have someone confirm all seems ok
No smoke came out and no one died so I knew I was on the right path. (-;
 

Simi 60

Solar Enthusiast
Joined
Jul 10, 2021
Messages
123
And after a night's rest this is the result
 

Attachments

  • IMG_20211118_175050_603.jpg
    IMG_20211118_175050_603.jpg
    1 MB · Views: 20
  • Screenshot_2021-11-19-05-12-43-461.jpeg
    Screenshot_2021-11-19-05-12-43-461.jpeg
    493.2 KB · Views: 19

Simi 60

Solar Enthusiast
Joined
Jul 10, 2021
Messages
123
Well, I guess that proves that matched and batched cells from Amy are worth the extra.
The first battery I "top balanced" the cells 4 at a time
But the second battery I just assembled and charged and had seemingly better results.
Though it is interesting seeing the battery reading 280ah and 100% yet the cells are only in the 3.4v range.

Should I keep pushing it in until they get to 3.64ish?
 

Attachments

  • Screenshot_2021-11-20-06-18-33-925.jpeg
    Screenshot_2021-11-20-06-18-33-925.jpeg
    505.5 KB · Views: 6
Top