diy solar

diy solar

LiFePO4 Sudden voltage drop to 1%

Julian-Indaiatuba

New Member
Joined
Nov 5, 2019
Messages
45
Hello,

About 4 months ago, I exchanged by 8 lead acid batteries for one LiFePO4 100Ah battery, made by Unicoba, which is a renowned company with decades of experience in manufacturing batteries here in Brazil.
At about 10:30 pm every night, I switch the inverter, a Growatt SPF3500ES, to battery power only, which runs my house until the sun comes up, when the battery starts charging again, and the inverter uses both the sun and battery power. When the sun goes down, I switch the inverter to grid power only, until I go to bed, and switch it back to battery.
I have set the inverter to switch back to grid power at 25% if the SOC should get to low during the night. This never really happens, except for about once a month when I get sudden percentage drops. For instance, last night the inverter shows that the battery SOC suddenly dropped from 31% to 1%, which makes the inverter switch back to the grid immediately. I really don’t understand why! Usually it runs perfectly using the battery’s bms.
I have added 4 images which show the battery’s details, the SOC during a normal night and day, and how the battery behaved last night.
Any suggestions on how to resolve this would be greatly appreciated.
Thanks in advance.
 

Attachments

  • IMG_0847.png
    IMG_0847.png
    199.9 KB · Views: 12
  • IMG_0845.png
    IMG_0845.png
    150 KB · Views: 12
  • IMG_0844.png
    IMG_0844.png
    156.2 KB · Views: 12
  • IMG_0843.png
    IMG_0843.png
    157.2 KB · Views: 8
Thank you so much for your reply.
I’m afraid I have no idea about the cell voltages, or how the SOC is monitored. I just use the data cable with which the battery bms is connected to the inverter.
I have attached a picture of the loads just before the SOC dropped. Also attached is the manual, but it is in Portuguese I’m afraid. I don’t think an English version exists.
 

Attachments

  • IMG_0848.png
    IMG_0848.png
    194.4 KB · Views: 14
  • Manual_T_cnico_Bateria_de_Litio_Unipower.pdf
    1.4 MB · Views: 10
I've just noticed this exact thing on my system last night sudden drop in SOC (21% to 5%) with no change in load (over night is around 300w to 400w) when it happened it triggered grid charging to 11% then stopped charging which is odd as my on grid cut off is 15%.

I've looked at all individual cell voltages and all internal temps of the system several minutes before and after the event and everything looks good.

My Battery is Hanchu ESS LV 9.4kWh which uses Lithium phosphate technology.

I was going to wait and see if it happens again and then take it up with my installer.
Picture1.jpg Picture2.pngPicture3.png

I've just looked further back in my data and found another instance of this not quite a extreme but on the 30/01/24 a drop of SOC from 15% to 5% with the same small overnight load which hardly changes.
 
Last edited:
I contacted my installer who went back to Hanchu (Manufacturer) who looked into my battery.

There response was that a SOC 'correction' had not been triggered for some time and a full charge and discharge cycle would trigger the correction and correct the issue.

I looked back and each time this happened for several days before my battery had only had partial charges and discharges and never really got full or empty so what they are saying does sound right. It would be interesting then to know how they determining the SOC ?

Sorry Julian this does not seem to be the same issue as your experiencing but hopefully this will be helpful to anyone who finds this thread looking for similar issues.

Hope you got yours sorted.
Ian
 
You have to look at the actual voltage, either of individual cells or total pack. I will bet you dollars to donuts that the voltage didn't drop.

There is virtually no equipment that will accurately track SOC.
 
You have to look at the actual voltage, either of individual cells or total pack. I will bet you dollars to donuts that the voltage didn't drop.

There is virtually no equipment that will accurately track SOC.
Yes your right the voltage did not drop

However the voltage did not 'match' the SOC, every time I've seen this happen the battery voltage has been down around 48.1 which i believe is around 5% SOC and this voltage is probably the lower trigger level for the correction/calibration hence the sudden drop of SOC to 5%

It does make sense to me now.
 
Back
Top