diy solar

diy solar

anyone recognize this brand of manifold?

callmeburton

New Member
Joined
Mar 4, 2022
Messages
240
I believe this was installed in Maine or Vermont, I forget which, and I acquired it second hand from the guy who removed it from the dwelling it was installed on. I am trying to identify the manufacture so I can more easily find components I need to put it back in use. I tried to find a valve to install at the compression fitting on these for example and nothing locally would work. A 3/4 compression fitting nut would "work" on the male to male adapter but the reverse wasn't true, the 3/4 threaded valve wouldn't allow the nut on the units to attach to the unit for compression testing.

This will be a drain back setup but I want to check the manifolds for leaks before installing it.

1703180575192.png
 
found my caliper

compression fitting male to male connector
1mm pitch
28mm OD
23mm ID

copper pipe is
19mm ID
~21.6 OD

not sure how to get this to a 3/4 standard yet. I haven't been able to find a compression fitting which goes from M28x1 to 3/4
 
Last edited:
So this thing is either chinese or japanese, I found markings on the 22mm fitting nuts from both countries.
 
UPDATE: For those that come across this and wondered what my solution was, I ended up swagging the manifold coper pipe up a bit to allow for a 3/4 brass union to be soldered on.
 
Was that an evacuated tube system?. I would be interested in age of tubes and how many were still working.

A local energy coop was big into evacuated tubes and reportedly failure rate was high. Manufacturer went bankrupt so many were junked or just left in place.
 
Was that an evacuated tube system?. I would be interested in age of tubes and how many were still working.
I suspect 5 years at least ... these came off someones house where they were using it to heat their home, I think it was 1500 sqft if I recall correctly. There are no dates on the unit or branding so far as I can tell ... there are some numbers on the bulbs though, I will look at them today to see if they have a date.

I had 3 tubes broken prior to me even picking them up, and 2 missing (broke by the guy who took them off the roof) ... rest of the glass is fine and has seals (easy to tell with these tubes) I will need to make plugs for the missing ones eventually.

The bulbs I believe are fine but that said I didn't take them all out to inspect them, I just checked to see they were still producing heat. Not sure what the failure rate is on bulbs though, it would seem low to me given how they work. The tube seals on the other hand ... some of those were "bad" so I siliconed them in place but I suspect it wont make much of a difference overall with the performance of the system given the dust seals around the tubes likely do most of the work. I can always "reseal" them again when I migrate it to the roof if I find it is a problem.
 
Back
Top