diy solar

diy solar

Growatt SPF-5000 ES with Daly BMS


New Member
Jan 22, 2024

I recently installed a LifePO4 16s battery pack at home as a back-up battery.
It's a home-made pack, I have a Growatt SPF-5000 ES inverter and a Daly 150A BMS with a CANBUS/RS connection. I had a small cable supplied.
I followed the instructions for connecting this cable to an RJ45 socket in the Growatt manual.
When I select the battery type on LI with the L004 protocol, the inverter goes into error. Error code 20.

I've checked my cable connections.
In the Android Smart BMS application, I selected Growatt and RS485.

I tested various solutions found on the internet (except firmware updates) but nothing worked.

I'm currently using the USER2 manual settings, but is there any way to make the inverter communicate with the BMS?

Hi can you elaborate on how you have solved the problem? Im also using DALY with Growatt. Thank you.

I bought the Daly interface card for Daly BMS.

You can find it on Aliexpress for example :
They call it parallel interface board

In the Growatt inverter, when you select Li (Menu 5), you choose protocol n°4.
Don't forget to configure the Smart Bms application to select "Growatt and RS485 protocol".
Bro after extensive research and trial and no success I was able to achieve the goal that manufacturers purposely set up to make you purchase their brand name system components only. I found your article and ordered your recommendation interface board set it up per your instructions and finally got the success of a Growatt inverter 5000es 250 amp Daly BMS, and a 560 ah Lifepo4 battery I built (Diy) to all communicate and run flawlessly. Thank You Koubiacz. You are greatly appreciated.
Hi Koubiacz. I'm trying also with a growatt, diy batteries en daly. The interface board has dipswitches. Do you need a special setting for those maybe? Because my daly connected through the interface board says read succesfully but invalid input. The growatt is set to Li and protocal 04

This question is to anyone offcourse who can help :):fp

I found the dipswitch settings but the problem stays. The bms says it reads the inverter (growatt) but then swithes the protocal to 'none'. When I press 'set' it's comes back with 'invalid input'. Mmm.. frustrating
Last edited: