diy solar

diy solar

Growatt SPF 5000ES + Seplos BMS - earth leakage protection (grid) triggers


New Member
Oct 10, 2023
Hi all. Please apologize in advance for the long post.

I set up a DIY pack of 16s3p EVE 280Ah EVE Lifepo4 cells, with a SEPLOS (V1) BMS and 2 Growatt SPF 5000ES inverters in parallel single phase @230V.
All worked fine since day 1, with a "particular" detail: the solar panels are not available yet so the system has been mostly shut off, only doing some cycle tests on the battery charging from the grid in off-peak times and supplying the house, all working fine. The BMS is communicating correctly with the inverter, reporting the SOC and the maximum charge current (P02 is dinamically set from the BMS)
I also installed a manual switch which allows the grid to power the house directly, bypassing the inverters.
The inverters are set up to "SBU priority" in P01 and CSO in P14.

After some days working like this (eg: charging from the grid+loads at off-peak hours, otherwise discharging to the loads) always through the inverters, including several discharges < P12, I woke up to a house without electricity: at some point during the nigh the battery got empty, for some reason the inverters didn't bypass correctly and the earth leakage protection device (300mA) from the grid triggered. No power from the battery or from the grid, the house went dark.
Next morning when I realized the problem I switched the manual switch to direct grid connection (leaving the inverters off) and went to work.

Later I did several tests, all of these with the manual switch to "off" position: there was no energy flowing to the loads, neither from the grid or from the inverters. At this point the battery was more or less discharged, having the lowest cell voltage >2,9V so no protection from the BMS was active at that time.
- I turn on the battery to the inverters, they turn on in full standby --> no grid detected, no AC output as the battery % reports < P12.
- I turn on the circuit breakers for the inverters AC IN, I expect the inverters to go into AC bypass + battery charge. The inverters show the AC IN present, after some seconds the earth leakage device triggers, before the AC output was activated (and it wouldn't matter if it was, the manual switch was "neutral").
- I tried a single inverter, both master or slave, the behavior was always the same. After enabling AC IN, the earth leakage device triggers. At that point I was more or less convinced that something was broken.
- Eventually I set P01 to "Utility First" (because why not?). I then turned on the breakers for AC IN, the inverters went to "AC bypass" and for the first time I could power on the loads from the inverters. But not only that, after a few seconds the battery was also being charged! So everything that before caused the earth leakage device to trigger was now working fine, except it was started in a different sequence.
- While everything was running I changed again P01 to "SBU", and everything was still working the same.
- The baterry was then charged to P13 and then went to power the loads, instead of the grid. All working fine again.

Because I want to understand what happened, I caused the battery to fully discharge the following night and the earth leakage device was triggered again and the house was again "dark" in the following morning.
What I *think* happens is some cells are not discharging evenly. So the BMS reports a certain % (which is > P12 on the inverters) but eventually some cell sinks below the minimum voltage alarm and the BMS shuts down the output. In the Growatt manual it is stated that for paralell operation the battery must be present, so if it is "cut" by the BMS the inverters somehow loose "sync" and that causes them to go "off-phase" which causes the earth leakage device to trigger. I'm not sure if that's the case, but if it is I accept that and it's up to me to balance the cells so that they don't "sink".

What I don't understand is why does the earth leakage device triggers after a total "reboot" of the system as described above, even with no outputs connected. It seems it wants to start charginf the battery but something prevents it from doing it and that causes the earth leakage device to trigger. If it goes to AC bypass, then the loads are supplied, no trigger occurs, and eventually (after few seconds) the battery is also charged. If I set it to charge the battery as a first priority, then the earth leakage device is triggered.

Again, please excuse the long post and I hope I was clear with the description.
Just a quick follow up. After several days attempting to figure out what the problem is, I finally found it...

The reason for the inverters shutting down is clear: the BMS entered low voltage alarm state and doesn't allow any discharge. I need to play with the settings to prevent such deep discharge.

But the reason for the earth leakage device triggering is actually quite stupid: I was powering the inverters and immediately turning on AC IN (or it was already on). The inverter boots and after few seconds goes to do *something* which causes the trigger.
If I power on the inverter only via battery, allow it to turn on the AC OUT (takes some 20-30 seconds maybe) and then turn on AC IN, everything works fine.
install earth leakage devices only on the output side of the Growatt SPF inverters. the input is only fused to prevent damage to the cables.

diy solar

diy solar