Juntek battery capacity meter issue?

Texas-Mark

Solar Addict
Joined
Aug 4, 2021
Messages
495
So I just got this meter and really like it so far except for one thing. When the battery is charging it display the amps flowing as a negative number and when discharging it shows it as a positive number. Before anyone asks, yes it is wired correctly and the charge/discharge indicator shows the correct action. I had set the battery capacity in the bat settings, and that is all I have done. Am I doing something wrong, or is this the way it is supposed to read? And if it is correct, why? Every other meter I have shows discharge as negative and charge as positive.

In the manual it says this for the bat menu item:
"This item can set the total battery capacity and real-time battery capacity."

All I see is one place to set the total capacity. Not sure what they mean by "real time capacity".

<edit> I did find how to set that "real time" (current battery %) but it did not change the negative positive thing.
 
Last edited:

Texas-Mark

Solar Addict
Joined
Aug 4, 2021
Messages
495
Well, after watching some youtube videos, I guess this is the way it works. Still seems bizarre to me.
 

RGIvy

Solar Enthusiast
Joined
Dec 9, 2020
Messages
78
We bought a Juntek VAT1200 (200A) in march from AliExpress and really liked it - and yes it displays opposite to Victron and other shunts but I can live with that.
We bought 20 VAT1050 (50A) shunts off Alibaba and they're also really good.
We then bought 20 VAT1200 (200A) shunts off a different seller on Alibaba and they have this problem:

So we now have 20 VAT1200 shunts that are not fit for purpose.

We bought a single VAT1200 (200A) from the original seller on AliExpress and it also has the newly-introduced problem. Useless to us unfortunately.

I can live with "positive amp hours drawn" but not this new error.
 
Top