Xiaoxiang BMS Carplonger app 280A Lifepo4 Battery


New Member
Aug 22, 2021
Im using a Xiaoxiang 150A BMS on my 280A Lifepo4 Battery consisting of 4 cells. I have been using this for about a year. Today I was putting on a new mmpt solar controller and noticed that the app im using said the battery had 179.8A. In 1 year I never noticed it was not reading 280A. It always got to 180A and it did not compute something was wrong. If I set the app parameters to 180A battery Amps the app reads 90A when charged. 1/2 what its supposed to read. Im using the caplounger app. Any ideas of how to fix it? other than set the max battery amps to 560A in the app.
any other apps that work on this BMS?

Last edited:
I am assuming that is a JBD BMS.

There is an xiaoxiangBMS App and an Overkill Solar app that both should work with this BMS

The other thing to be aware of with this BMS is that any time a setting change is written to the BMS it reverts to a guesstimated SOC based on the voltage of the pack and the voltage % settings in the App.
Once the pack is fully charged, it will change over to coulomb counting and track the amps in and out of the pack. You will want to do a full charge once in a while to keep things in sync.
Thanks for your answer. This is what I ordered in 2021 How can I tell if its JBD?

Dykbcells Smart BMS 4S 150A 12V LiFePO4 Li-ion Lithium Battery Protection Board W Balance Bluetooth APP high-Power Temperature Protection 3.2V 3.7V Battery Pack (4S LiFePO4 150A)

I already downloaded those apps before posting, but fell of the ladder replacing a running light and broke my foot. Ill probley try them tomorrow.
I already set the capacity at 280A but it stops at 180A and the cells are not full about 2/3 or more. Id I set the capacity to 180A it reads 90A. available
The 'function setting' causes the BMS to recalculate SOC based on voltage.
Last edited:
Yes I did all that However I loaded another app Overkill as suggeted and it worked. The I went back to the caplounger app and reads correct now. The xiaoxiangBMS App doesnt work at all. I cant find the blutooth. I like caplounger better because I can set all the parameters and cant with overkill, unless Im missing something.

Next I tried to use the caplounger app and it wants a serial number. I have no idea how I got it to work on the other phone.
Right now I have 279.8a available and the cells read. 3.24, 3.32, 3.325, 3.325

Propbly the caplounger app worked all alog and it just started acting up yesterday. Sometime blutooth is a pain. Anyway, thank you all.