More DALY smart BMS issues

Solar_Mann

Solar Enthusiast
Hopefully someone has some advice. I purchased a 100amp 4s daly smart bms from "srikobatteries" on ebay. My cells finally arrived after nearly 2 months, got it all hooked up and it is charging through the BMS without issue however i can not get the bluetooth or PC to communicate. In the smart BMS app on my iphone the bluetooth dongle never pops up to be selected. I download both the PCMaster and Sinowealth software, got the usb to UART adapter to connect to my laptop neither program is able to display any information from the BMS. It seems as if the UART port on the BMS is dead. Is this just another case of shitty china quality? Anyone dealt with this vendor off ebay? I have an email in with them but no replay yet.

Thank you to anyone with some information!
 

lexio

feel the balance 3.65
Sinowealth software choose xxxxf03 and the com port in the software hit the SCAN ALL BUTTON you can try all com ports
 

Uoavitar

Boondocker
I had a minor issue with my smart 250 I got from Daly off of Amazon today. I ordered the

DALY Smart BMS with UART / RS485 / Cooling Fan 4S 12V 250A LiFePO4


And the touch screen and Bluetooth with it. I got the BMS all wired up and working but the touch screen showed no data. Everything was zeros. I unplugged it and plugged in the Bluetooth and it worked perfectly with the app downloaded from the Google play store.. Leads to believe there may be something wrong with the touch screen but this was my first time using any of this so I may be doing something wrong myself.
 

Solar_Mann

Solar Enthusiast
Sinowealth software choose xxxxf03 and the com port in the software hit the SCAN ALL BUTTON you can try all com ports

Thanks for that tip, just tried it and still nothing.

Also figured I’ll add this....the only way I can get the BMS to turn on is to plug in the UART to usb cable. The second I plug that in the BMS turns in. Still no info via pc or Bluetooth though.
 

Attachments

  • 400D2E60-BE05-4817-9382-9C7C873AD17D.jpeg
    400D2E60-BE05-4817-9382-9C7C873AD17D.jpeg
    98 KB · Views: 46

Nakinto

Solar Enthusiast
Thanks for that tip, just tried it and still nothing.

Also figured I’ll add this....the only way I can get the BMS to turn on is to plug in the UART to usb cable. The second I plug that in the BMS turns in. Still no info via pc or Bluetooth though.
YEP, I am having the same issue, of course AFTER I post my problem I find yours LOL. I will be watching your post if ANYONE has any information, On the phone I can get some of the third parties to at least connect to the Bluetooth, but it reads like "23%" when the batteries are at 57.2v (Li-Ion 100 is around 58 and I don't want to go there...) No way is the voltage curve THAT flat :) And of course the bluetooth I can't change ANY settings. Oh, and the "SmartBMS" by DalyBMS can't even SEE the bluetooth... I do love that wonderful Chinese quality! Of course there isn't anything that even OFFERS this kind of user editing capabilities outside of this one BMS...
 

BoloMKXXVIII

Fully Charged
I had a different issue with a Daly BMS. It worked for about 5 minutes and quit. Will inferred I did something wrong but the Daly build was not my first build. I replaced the Daly with an Onerkill BMS and haven't had a problem since.
 

Nakinto

Solar Enthusiast
I had a different issue with a Daly BMS. It worked for about 5 minutes and quit. Will inferred I did something wrong but the Daly build was not my first build. I replaced the Daly with an Onerkill BMS and haven't had a problem since.
Do you mean your BMS stopped working? Or the voltage went wrong? OR? Daly has to be installed in a specific order I found out... irritating IMHO... I looked up the Overkill BMS, looks identical to the Daly?
 

BoloMKXXVIII

Fully Charged
It worked perfectly...for about 5 minutes. Then was dead and couldn't be woken up. The Daly and Overkill are very different. The connections are the same though.
 

Pim57

Solar Enthusiast
Hopefully someone has some advice. I purchased a 100amp 4s daly smart bms from "srikobatteries" on ebay. My cells finally arrived after nearly 2 months, got it all hooked up and it is charging through the BMS without issue however i can not get the bluetooth or PC to communicate. In the smart BMS app on my iphone the bluetooth dongle never pops up to be selected. I download both the PCMaster and Sinowealth software, got the usb to UART adapter to connect to my laptop neither program is able to display any information from the BMS. It seems as if the UART port on the BMS is dead. Is this just another case of shitty china quality? Anyone dealt with this vendor off ebay? I have an email in with them but no replay yet.

Thank you to anyone with some information!
Make sure that the balance wires are correctly connected. If not, it can destroy the BMS.

If the balance wires are oke, then when you plug them into the BMS it should come to life.
Also the bluetooth will wake up. You can't see the bluetooth when scanning for BT devices as it is hidden. Only the smart bms app from Daly can discover it.

After 1 hour of inactivity the bluetooth and UART shuts down (save power). It can be woken by momentarely connecting the two trigger wires. The two trigger wires sit in a 2-pole connector on the bms.

No plug for this connector came with the BMS so you need to make this yourself. Touching the two trigger pins with a small screwdriver will do the trick as well.
 

Bsjoling

New Member
:-/
My touchscreen shows no data. Turns on ok, is in english, just full of blanks & 0 !
If I unplug it and stick the bt on it everything is working and dispalying as expected, and of course I can change the paramaters.
Pluging the screen back in and everything is working, in terms of light charging current (10a) and discharge, just no info!
 

Just John

Solar Addict
Thanks for that tip, just tried it and still nothing.

Also figured I’ll add this....the only way I can get the BMS to turn on is to plug in the UART to usb cable. The second I plug that in the BMS turns in. Still no info via pc or Bluetooth though.

Be sure to install the driver.
 

Bsjoling

New Member
I had a minor issue with my smart 250 I got from Daly off of Amazon today. I ordered the

DALY Smart BMS with UART / RS485 / Cooling Fan 4S 12V 250A LiFePO4


And the touch screen and Bluetooth with it. I got the BMS all wired up and working but the touch screen showed no data. Everything was zeros. I unplugged it and plugged in the Bluetooth and it worked perfectly with the app downloaded from the Google play store.. Leads to believe there may be something wrong with the touch screen but this was my first time using any of this so I may be doing something wrong myself.
did you get to the bottom of this one? I'm seeing what daly have to say, slow going tho...
 

Uoavitar

Boondocker
did you get to the bottom of this one? I'm seeing what daly have to say, slow going tho...
I didn't even try, I just plugged in the BT module and used it instead. I figured I would try it again on the next BMS and if it still didn't work right then probably just toss it.
 

Bsjoling

New Member
I didn't even try, I just plugged in the BT module and used it instead. I figured I would try it again on the next BMS and if it still didn't work right then probably just toss it.
:) I'm chatting with daly to see if it can be recovered. Be nice to have it working right, bt is cool, be nice to not have to use my phone all the time.
I shall post my findings. They are saying I haven't initialised the bms properly... will see how it pans out
 

SherylinRM

GO GO JUICE BOOMER ZOOMER MAKER
I have three phones and a tablet and it only works on one very old phone.
Also the uart never worked. Nothing, zippo.
So I am looking forward to anything that could fix this. :)
 

Bsjoling

New Member
Result!
I got it working. Daly sent me the attached files after much badgering and I managed to stumble my way through.
Touchscreen is working.. looks like it can set values too, early days yet. Needed a firmware update, but all is explained reasonable well.
happy days (touch wood)
 

Attachments

  • Sinowealth BMS Tool Setup V0.1(Temp)(1).zip 中颖上位机.zip
    2.3 MB · Views: 49
  • wetransfer-917520.zip
    4.6 MB · Views: 53
  • more bits.zip
    4.7 MB · Views: 48

Just John

Solar Addict
Result!
I got it working. Daly sent me the attached files after much badgering and I managed to stumble my way through.
Touchscreen is working.. looks like it can set values too, early days yet. Needed a firmware update, but all is explained reasonable well.
happy days (touch wood)

Some others have reported having to update the firmware before they could use the touchscreen as well. I think they also said it was either touchscreen or bluetooth, not both. In other words, you either flash it to use the touchscreen, or flash it to use bluetooth. You can't swap between the two without reflashing. Is that the case for you?

BTW, I think these files are in the resources section here on the forum.

 

SherylinRM

GO GO JUICE BOOMER ZOOMER MAKER
Result!
I got it working. Daly sent me the attached files after much badgering and I managed to stumble my way through.
Touchscreen is working.. looks like it can set values too, early days yet. Needed a firmware update, but all is explained reasonable well.
happy days (touch wood)
Thank you. :)
 

Philtinks

New Member
Hi guys, I have the daly 250amp 4s smart. it wakes up ok, I get 13ish volts in but only 10v ish out. Double and treble checked wiring and all ok. Any suggestions please? Have I fried it by plugging BT &/or temp into wrong sockets? Or is it just faulty. Tried charging but will not charge through BMS
thanks. Phil
 

Uoavitar

Boondocker
Hi guys, I have the daly 250amp 4s smart. it wakes up ok, I get 13ish volts in but only 10v ish out. Double and treble checked wiring and all ok. Any suggestions please? Have I fried it by plugging BT &/or temp into wrong sockets? Or is it just faulty. Tried charging but will not charge through BMS
thanks. Phil
It's not actually woke up, there are 2 pins in a socket for the Daly SOC monitor that you have to short together to get it to wake up. I have the same BMS and it did the exact same thing until I shorted the 2 pins with a test lead. I'll dig mine out and get you a picture shorty.
 
Top